EH Scott Radio Enthusiasts

The Fine Things are Always Hand Made

Hello all, I am so glad I have found you all! I have been interested in vintage audio for a while. I have been slowly building my collection. most of my items are early Stereo pieces from the late 1950s. I happen to come across a beautiful, 1947 Scott 16A Metropolitan. I was told that it had worked at one point, but hadn’t been used in years. I took the bottom off the amp and tuner and noticed that most of the capacitors were already changed. I powered it up slowly, no crazy amp draw. It played through the Television input and the phono input, but it lacked volume.

I tested the tubes and found a few bad tubes (6SG7) there are 5 in the unit 2 were bad, not sure where the bad ones go and somebody had put a random rectifier tube in place of a 6SL7GT (2nd AF Amp).

Replaced the bad and missing tube and it sounds fantastic but still a few issues. I was checked 95% if the resistors and about 75% of them are within 15% of their ratings. A few are 20%. And there are 1 or 2 that way out of spec. Will be replacing those this week.

The issues I’m currently having is that I get no reception on AM or FM. No static, it’s like the tuner just isn’t working. The tuning eye does work but doesn’t change when I attempt to tune the radio.

Also the Bass control seems to do nothing one way or another.

Is there anything obvious to you guys that I can check? Thank you so much!!

Views: 70

Reply to This

Replies to This Discussion

The set won't do anything without an antenna. For FM, a basic dipole should get local stations. A single wire will get stuff on AM. If you've tried with antennas connected, it may require some technical troubleshooting. 

Kent 

I have not tried with an antenna. I will connect one and give it a shot.
Tried a loop on AM and a Dipole on the FM. Nothing. Eye not changing and no reception

Well, what I'd try next is a signal generator, set it to a good AM frequency and see if you can push a strong signal through the set. 

Kent

That is some thing I do not have. Haven’t had a need for one until now. But I will try to follow the signal path checking components on the way.

There appear to be some paper capacitors left in the tuner, and there are still a handful of resistors that are bit out of spec. I will focus on those circuits and see what I can come up with.

In most cases resistors being out of spec won't leave a radio dead silent unless they are setting a tube bias, like a cathode resistor, and they are off quite a bit.  You can check the tube voltages and see what you have there.    Definitely replace the remaining paper capacitors.  Without a signal generator to inject a signal and isolate a stage it will be a bit harder to troubleshoot.  Check the band change switch for proper contact and operation.  Your eye tube won't operate unless you have a signal passing thru and the AGC is working. 

Thank you. I’ll start with the capacitors. Will the eye tube be lit while other radio functions are on? The Eye is always lit on just never closes.

I am not familiar with the 16A operation and not sure if it is supposed to switch off in other modes, like phono.  But it will stay open if it is not getting a signal to it's grid. 

Not sure if you know, but if you go to the top of this page, in the upper far right there is a link titled "Archive".  If you click on that it takes you to archived EH Scott literature.  Go down to "set folders" and you can get the service info on the 16A in the appropriate folder. 

Thank you. I’ll check it out. I believe Kent emailed them to me. But I will see if there is anything else.

Reply to Discussion

RSS

© 2022   Created by Kent King.   Powered by

Badges  |  Report an Issue  |  Terms of Service