EH Scott Radio Enthusiasts

The Fine Things are Always Hand Made

Need ideas folks: I've got an AW23, fully restored, used to work well. Tried it this week and it powered up ok, but the neon VRs lit, dimmed as the tubes came alive and the went out. Set doesn't play, but a 465khz signal into the IF is strong, phono input works. 

I"m sure the local osc isn't working, pulls the voltage down to about 100v when the neon bulbs go out. No radio signals...The resistor in the circuit was not a 75k as shown in the schematic, it was a 100k, and it read 130k. So I found a dogbone 75k (read 75k), and replaced it. Same results.

Any ideas what else to look at in the osc circuit?\

Kent

Views: 88

Reply to This

Replies to This Discussion

I presume that you have swapped the tube to see if that helps, is the 50pf cap to the oscillator grid ok. I have had similar problems with a similar circuit in the past.

Is the turret making contact with the coils, may seem a stupid question but you never know, is the resistor to the regulator tubes the correct value?, the fact that the regulators light would seem that this is ok, but worth a check.

Is the tuning cap ok, no shorts vanes touching etc.

Mike

I have tried several tubes, currently using a NOS mil spec 76. I next need to remove the tuning capacitor cover and look in there. No short on the ohmmeter, but could be something else. I spent a good bit of time thinking about it - I could replace the <entire> circuit if necessary - swap tuning cap, coils, even replace the socket. I've got enough spare parts to do that. Over the next week or so, I'll take some of these more drastic steps to see what happens. The 50pf cap goes next, since it's easy.

If the regulator tubes drop out it is due to high current in the oscillator tube.  This is most likely due to a bias problem or parasitic oscillation.  I suspect the latter.  It is also possible that the entire B+ supply drops due to current draw elsewhere in the set but from your description of operation I think this is unlikely.  Mid-production run, the E.H. Scott Radio Laboratories relocated the ground return from the oscillator cathode from the terminal strip to a dedicated ground immediately adjacent to the cathode lug on the tube socket (possibly the rivet used to secure the tube socked - I will have inspect a chassis to know).  If not for the coil wheel, this can be tested by using a screwdriver to short the cathode lug directly to the chassis.  Under the coil wheel, that is not so easy.  Another problem that develops over the years is the connection between the tuning capacitor stators and the solder lug for the stators.  Machine screws were used through a phenolic insulator to electrically connect the solder lug to the stator plates.  Over time the phenolic insulator shrinks allowing corrosion to develop between the machine screw and the solder lug.  If you have not already done so, remove the tuning capacitor, loosen and retighten the machine screws.

Norman

Thanks Norman...I have decided I'm going to remove the tuning cap and refresh it. I never replaced the rubber covered wire on this set (still very pliable), but I'm going to replace it all from the tuning cap. This set has a dedicated ground lug riveted to the chassis right next to the cathode pin - but, last night, I reflowed the solder and the ground lug came off, broken at the rivet. It may have been weak, bent at the factory and was an ineffective ground. I'm going to drill out the rivet and replace it with a new ground connection. I'm hopeful those two things (tuning cap and ground lug) will resolve it.

But first....I'm off to the Estes radio auction tomorrow. A few nice items and over 30 battery superhets to look at.

Kent

Kent, I'm working on a Ph!l@o radio right now, and I've discovered some grounding issues in it as well...some of the methods of using existing screws/bolts, or soldering to other components isn't the best method of grounding, as we now know. But, then again, the designers of our sets, no matter what price range they were in, never expected them to be around in 80 years...never mind being restored!

Give us an update on what you bought at the auction!

Brad

The only item I bought for myself was a box of early Radio Age magazines - resulting in 5 additions to my collection and a couple "upgrades". I bought a few battery supers for another friend of mine, but that was it. The WRS10 in the auction was just more than I wanted to go, since i already have one and it wasn't a big improvement for me...

Update - So I took this set down a bit and replaced all the rubber covered wire in the "front end", from the band switch contacts to the SW coil, the grid leads to the front end tubes, etc. Removed the main tuning cap and put all new leads on it, tightened all the screws and refreshed the ground connections. Drilled out the rivet for the osc cathode ground and replaced it. Reconnected everything and returned shields etc. And guess what - it works!! The neon bulbs stay on, set plays well. I'll do a few more touch up items and put it back into its cabinet. Norman hit it - parasitic oscillation, too many weak/loose grounds and such. 

Kent

Hmmm. trusting grounds through rivets and  star washers seems a bit dubious. On  the AM/FM Philly I'm in process of right now, I don't trust rivet grounds, especially through a freshly plated chassis.  So, I'm soldering several ground locations to the chassis and running a ground wire from every ground point to the next.  Hope I don't run into a ground loop problem!.

Well, I found lots of little grounding issues when I took the 23 apart. The screws on the main tuning cap weren't super tight, I re-flowed numerous grounds and when I drilled out the rivet for the osc cathode ground, I hardly touched it with a drill and it came loose - so I'm sure that was an issue. I cleaned the metal around the hole and put a screw with a new solder lug in extra tight. Passed a solid heavy piece of copper wire from the cathode lead on the socket to the new ground lug. I think there were multiple grounding issues in this set.

Reply to Discussion

RSS

© 2021   Created by Kent King.   Powered by

Badges  |  Report an Issue  |  Terms of Service